Umstellung auf PHP 5.3.8

Am 19.10.2011 stellen wir unsere Systeme auf die derzeit aktuelle PHP Version 5.3.8 um.

Mit der neuen PHP Version werden Sicherheitslücken geschlossen und zahlreiche neue Funktionen zur Verfügung gestellt, welche ihr in euren Scripten verwenden könnt. Eine zeitgemäße Entwicklung wird euch somit ermöglicht.

Darüber hinaus öffnet PHP 5.3 die Möglichkeit, aktuelle Versionen von CMS, Foren, Blogs, usw. zu installieren, welche PHP 5.3 voraussetzen.

Eine Zusammenfassung der dadurch entstehenden Änderungen haben wir für euch im entsprechenden Ankündigungsthread zusammengestellt.

4 Kommentare

  1. Nun das wird auch mal Zeit, wenn ihr die PHP Version Updatete. Warum macht ihr das eigentlich nicht regelmäßig?

  2. Weil wir auch auf die User Rücksicht nehmen wollen. Nicht alle Sachen laufen immer mit einer neueren PHP-Version.

  3. Diese Ausrede hab ich auch noch nicht gehört … 😉

    Die aktuellste PHP-Version sofort zu installieren ist zwar keine gute Idee (siehe 5.3.7), aber ich wüsste jetzt nicht, welche Standard-Web-Anwendungen mit 5.2.17 laufen und mit 5.3.8 nicht …

    Eher ist das Gegenteil mehr und mehr der Fall, weil einige Features von 5.3.x in der 5.2-er Serie eben fehlen (Namensräume, echte Closures, static und der ganze Kram), die von aktuellen Libraries und Frameworks benutzt werden.

  4. Es geht ja auch nicht nur um neie Befehle, Bibliotheken und so. Es ist ja auch sicherheitstechnisch für den Server besser, wenn alles halbwegs aktuell gehalten wird.

Kommentare sind geschlossen.